Chicago Outage
Incident Report for AsutechIO
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 01:37 UTC
Investigating
Aware of an outage in the Chicago region and are currently investigating.
Posted Oct 14, 2021 - 01:10 UTC